Browse Source

add missing dep on menhir

dunesegfault
zapashcanon 2 years ago
parent
commit
33a6d0129c
Signed by: zapashcanon GPG Key ID: 8981C3C62D1D28F1
  1. 2
      .build.yml
  2. 1
      complice.opam
  3. 1
      dddddml.opam
  4. 8
      dune-project

2
.build.yml

@ -15,7 +15,7 @@ tasks:
- setup: |
opam init -y
opam update -y
opam install -y dune bisect_ppx odoc ocamlformat
opam install -y dune bisect_ppx odoc ocamlformat menhir
- lint-format: |
cd $GIT_REPO_NAME
eval "$(opam env)"

1
complice.opam

@ -12,6 +12,7 @@ depends: [
"ocaml" {>= "4.05"}
"dune" {>= "2.0"}
"bisect_ppx" {>= "1.4"}
"menhir" {>= "20200211"}
]
build: [
["dune" "subst"] {pinned}

1
dddddml.opam

@ -12,6 +12,7 @@ depends: [
"ocaml" {>= "4.05"}
"dune" {>= "2.0"}
"bisect_ppx" {>= "1.4"}
"menhir" {>= "20200211"}
]
build: [
["dune" "subst"] {pinned}

8
dune-project

@ -30,7 +30,9 @@
(dune
(>= 2.0))
(bisect_ppx
(>= 1.4))))
(>= 1.4))
(menhir
(>= 20200211))))
(package
(name complice)
@ -43,6 +45,8 @@
(dune
(>= 2.0))
(bisect_ppx
(>= 1.4))))
(>= 1.4))
(menhir
(>= 20200211))))
(using menhir 2.1)

Loading…
Cancel
Save